Installing VPython on Linux/Unix:

Here are Fedora Core 7 packages, both stable and beta versions, courtesy of Brad Longo, who writes, "None of the VPython beta versions will compile on Fedora, only the stable version will. I have talked with other people who use Fedora 8, and they did not even get the stable version to compile so I could at least give them that. As far as I know there is not a current solution to getting the beta version to compile on Fedora 8. When trying to compile it complains about boost-libs. There are boost files that are deprecated for Fedora 8, and our consensus was that was the reason for the beta version not compiling.  I have not tried to get one to work since 4.beta20. I may try another soon since I noticed a lot of progress through emails. I cannot make rpms for Fedora 7 anymore because I now have Fedora 8. However I can supply the spec file and instructions for making an rpm. Its really very, very simple. I have done all the work. This way if some one wants to compile a newer beta version it will be possible."

visual-3.2.9-1.fc7.i386.rpm

visual-4.beta16-1.fc7.i386.rpm

visual-debuginfo-3.2.9-1.fc7.i386.rpm

visual-debuginfo-4.beta16-1.fc7.i386.rpm

gtkglarea-1.2.3-1.fc7.i386.rpm

gtkglarea-debuginfo-1.2.3-1.fc7.i386.rpm

gtkglarea-devel-1.2.3-1.fc7.i386.rpm

Also from Brad Longo, packages for Fedora 9:

visual-4.beta26-1.fc9.i386.rpm

gtkglarea-1.2.3-1.fc9.i386.rpm

gtkglarea-1.2.3-1.fc9.src.rpm

gtkglarea-devel-1.2.3-1.fc9.i386.rpm

[VPython home page] [other platforms]